4.3. Account Register/General Ledger

4.3.1. Account Register & General Ledger Window

This window is used to enter and edit your account data. It also provides tools for scheduling future transactions, finding and reporting on transactions and printing checks.

To open the Account Register Window for an account, select the account in the Account Tree then go to FileOpen Account or press Ctrl+O. This will open a new window with the Account Register. Pressing the Open button on the Toolbar in the Account Tree Window or the Jump button in the Account Register Window are alternate methods.

Figure 4.3. The Account Register Display.

Account Register screen

This is an image of the Account Register tab.


Appearance of the Account Register Display is highly customizable (see Section 6.1, “Changing the Register View”).


The methods to enter transactions are described in detail in Chapter 6, Common Transaction Operations.

4.3.2. Account Register Menus

The Menubar for the Transaction Register window contains the following options. Account Register - File Menu

The following table describes the options in the File.

Clicking on File in the Menubar will pull down a menu of choices described in Table 4.11, “Account Register - File Menu - Access to file and account operations and printing.”.

Table 4.11. Account Register - File Menu - Access to file and account operations and printing.

Menu Item


New File (Ctrl+N)

Creates a new data file (starts with new accounts and data.)

Open... (Ctrl+O)

Opens an already existing GnuCash data file.


Opens the Import sub-menu to import files from other financial programs.


Import QIF ...

Starts the QIF file Import process.


Import OFX/QFX ...

Starts the OFX/QFX file Import process.


Import CSV/Fixed-Width ...

Starts the CSV/Fixed-Width file Import process.


Replay GnuCash .log file...

Starts the replaying of a GnuCash log file. Used for data recovery from "crashes".


Import MT940



Import MT942



Import DTAUS



Import DTAUS and send


Save (Ctrl+S)

Saves the currently open file.

Save As... (Shift+Ctrl+S)

Saves the currently opened file with a different name.


Do NOT store your data file in ~/.gnucash/books.

Print Checks... (Ctrl+P)

Starts the Print Checks assistant. See Section 6.14, “Printing Checks”.

Page Setup... (Shift+Ctrl+P)

Let you choose the paper size, layout and margins for printing.


Exports ...


Export Accounts

Exports your account hierarchy to a new file. Does not export data.

Properties (Alt+Enter)

Sets options for this GnuCash data file.

Recently opened files

Numbered list of most recently opened GnuCash data files.

Close (Ctrl+W)

Closes the current open account tree, transaction register or report. In the initial Account tree this item is not available - it will be grayed out.

Quit (Ctrl+Q)

Exits GnuCash. Account Register - Edit Menu

Table 4.12. Account Register - Edit Menu - Access to file and account editing operations and preferences.

Menu Item


Cut (Ctrl+X)

Performs a standard Cut operation.

Copy (Ctrl+C)

Performs a standard Copy operation.

Paste (Ctrl+V)

Performs a standard Paste operation.

Edit Account

Open form to edit/modify account characteristics and parameters.

Find... (Ctrl+F)

Set criteria for a search for a specific transaction. See Section 7.1, “Find” for specifics on searches.

Preferences (GnuCashPreferences on Mac OS X).

Customize GnuCash for location, style, and numerous other preferences. See Section 9.2, “Setting Preferences”.

Style Sheets

Modify/customize Style Sheets.

Tax Report Options

Set tax characteristics on account(s) (US). Assign tax form and line to account. See Section 9.4, “Setting Tax Report Options”. Account Register - View Menu

Table 4.13. Account Register - View Menu - Changes GnuCash display window characteristics.

Menu Item



Check-box to enable/disable display of Toolbar.


Check-box to enable/disable display of Summary Bar.


Check-box to enable/disable display of Status Bar.

Basic Ledger

Radio button to select register display mode.

Auto-Split Ledger

Radio button to select register display mode.

Transaction Journal

Radio button to select register display mode.

Double Line

Check-box to enable/disable display of Double Line display.

Sort by ...

Set the sort order of the transactions display. Requires a click to start options form. Option form requires Cancel/OK to close.


Standard Order

Keep normal account order



Sort by date


Date of Entry

Sort by date of entry.


Statement Date

Sort by the statement date (unreconciled items last).



Sort by number.



Sort by amount.



Sort by memo.



Sort by Description.



Sort by action field.



Sort by notes field.

Filter by ...

Set filtering for accounts displayed in the Account Tree or transactions in Register display.

Refresh (Ctrl+R)

Repaint the display screen.

New Accounts Page

Open a new tab that display the account tree. Account Register - Transaction Menu

Table 4.14. Account Register - Transaction Menu - access to transaction tools.

Menu Item


Cut Transaction

Cut the selected transaction into the clipboard.

Copy Transaction

Copy the selected transaction into the clipboard.

Paste Transaction

Paste the selected transaction from the clipboard.

Duplicate Transaction

Insert in the register a copy of the selected transaction.

Delete Transaction

Delete the selected transaction.

Remove Transaction Splits

Remove all splits from the selected transaction.

Enter Transaction

Enter in the register the transaction you are currently working on.

Cancel Transaction

Void Transaction

Void the selected transaction.

Unvoid Transaction

Unvoid the selected transaction.

Add Reversing Transaction Account Register - Actions Menu

Table 4.15. Account Register - Actions Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.

Menu Item


Online Actions

This menu item (and sub-menu) is shown only if Online Banking was enabled for GnuCash

Get Balance


Get Transactions

Download transactions from online accounts


Issue Transaction...

Upload transaction(s) to online account ??


Internal Transaction...


Direct Debit...

Scheduled Transactions

Scheduled Transactions sub-menus

Scheduled Transaction Editor

Invoke tool to edit scheduled transactions. See Section 6.13, “Edit Scheduled Transaction Window”


Since Last Run...

Display Scheduled transactions since last running of GnuCash. Section 7.2, “Since Last Run Assistant”


Mortgage & Loan Repayment...

Starts the Mortgage & Loan Repayment assistant for setting up repayments. Section 7.3, “Mortgage & Loan Repayment Assistant”


Budget sub-menus

New Budget

Opens the window to create a new budget.


Open Budget

Opens an existing budget.

Transfer... (Ctrl+T)

Starts the Transfer assistant for transfer between accounts.


Start the Reconcile process for the selected account. Section 5.8, “Reconciling an Account to a Statement”

Stock Split...

Starts the Stock Split assistant. Additional details Section 7.4, “Recording a Stock Split”

View Lots...

Opens the Lots in Account form.

Blank Transaction

Move to the blank transaction at the bottom of the register

Split Transaction

Expand the currently selected transaction to show splits.

Edit Exchange Rate

Edit the exchange rate for the current transaction.


Create a Scheduled Transaction with the current transaction as a template.


Jump to the corresponding transaction in the other account.

Check & Repair

Check & Repair Submenus


All Transactions

Check for and repair unbalanced transactions and orphan splits in this account.


This Transaction

Check for and repair splits in this transaction.

Reset Warnings...

GnuCash gives warnings when certain operations are attempted, such as removing a transaction or removing the splits of a transaction. The warning message gives you the option to not give you these warnings when attempting the operation. Check-boxes labeled Remember and don’t ask me again and Remember and don’t ask me again this session allow disabling the warnings. This option resets the warnings to the default, This option resets the warnings to the default, i.e. display all warnings.


Warnings may be selectivly enabled.

Rename Page

Open the form to rename the current page/tab. Account Register - Business Menu

The items shown in the Business menu are the same listed in Table 4.5, “Account Tree - Business Menu - Access small business features of GnuCash.”. Account Register - Reports Menu

The items shown in the Reports menu are the same listed in Table 4.6, “Account Tree - Reports Menu - Access GnuCash Reports and Charts.” plus the two types of report listed in the following.

  • Account report

  • Account Transaction Report Account Register - Tools Menu

The items shown in the Tools menu are the same listed in Table 4.7, “Account Tree - Tools Menu - Access to miscellaneous tools and editors”. Account Register - Windows Menu

The items shown in the Windows menu are the same listed in Table 4.8, “Account Tree - Windows Menu”. Account Register - Help Menu

The items shown in the Help menu are the same listed in Table 4.9, “Account Tree - Help Menu - Access to this help and the Tutorial and Concepts Guide.”.

4.3.3. Account Register - Toolbar Icons/Buttons

The GnuCash main Window has a number of icons/buttons in the Toolbar to quickly access some common functions used with the specific active tab. The Toolbar can be hidden or shown by selecting the Toolbar item on the View menu.


The specific options displayed in the Toolbar varies by the functions available to the active tab.

A brief description of the function of a button is displayed when the mouse pointer is placed over the button for a couple of seconds.

Table 4.16. Account Register (Transaction Register) Window Toolbar

Toolbar Buttons


Save (Ctrl+S)

Perform a save on the data file, commit all transactions to the data file.


Close this register.


Make a copy of the current transaction.


Delete the current transaction in this register.


Record the current transaction.


Cancel the current transaction.


Move to a blank transaction at bottom of register.


Show all splits in the current transaction. Not highlighted if ViewAuto-Split Ledger is enableb.


Jump to the corresponding transaction in the other account


Create a Scheduled Transaction with the current transaction as a template.


Start the transfer assistant to transfer funds from one account to another.


Start the Reconcile process for the selected account. Section 5.8, “Reconciling an Account to a Statement”

4.3.4. Tab Bar

The Tab bar displays notebook/file folder style tabs for open transaction registers, account trees and reports.

4.3.5. List of Transactions

The List of Transactions displays transactions you have entered and a running balance. It also provides a blank transaction to enter new transactions. The column headings vary according to what type of account you have opened. Common headings are Date, Description, Transfer and Balance.

The View menu can be used to alter the appearance of the List of Transactions. Possible changes are limiting the number of transactions shown, using a different sort order and changing the style to more easily see transactions. The Split button also provides quick access to view all the parts of a transaction.

4.3.6. Summarybar

The Summarybar displays balances appropriate for the opened account type at a glance. Usually accounts display Present (today’s) account balance, any balance for Future dates, a balance for Cleared items, a Reconciled balance and a Projected Minimum balance. Stock accounts, however, display shares totals and their value. The Summarybar can be hidden or shown by selecting the ViewSummarybar item.

4.3.7. Statusbar

The Statusbar works the same as described in Section 4.2.6, “Statusbar”.