4.4. Report Window

4.4.1. Report Display Window

This window is shown whenever a report or chart is selected from the Reports menu.

To open the report window, select a report from the Reports item in the Menubar. This will open a new window with the report displayed. It provides a web browser type display with active links to account data.

Note

Depending on the report there may be a delay while the report is generated. An approximation of the progress to completion is displayed in the Statusbar, if has not been opted out of displaying.

Figure 4.4. The Report Window

Report screen

This is an image of the Income/Expense Chart.


4.4.2. Report Menus

The Menubar for the report window contains the following options.

4.4.2.1. Reports - File Menu

The following table describes the options in the File Menu.

Clicking on the File option of the Menubar will pull down a menu of options described in Table 4.17, “Report - File Menu - Access to file and account operations and printing.”.

Table 4.17. Report - File Menu - Access to file and account operations and printing.

Menu Item

Description

New File (Ctrl+N)

Creates a new data file (starts with new accounts and data.)

Open... (Ctrl+O)

Opens an already existing GnuCash data file.

Import

Opens the Import sub-menu to import files from other financial programs.

 

Import QIF ...

Starts the QIF file Import process.

 

Import OFX/QFX ...

Starts the OFX/QFX file Import process.

 

Import Accounts from CSV...

Starts the CSV Account file import process. The file to import must be in the same format as the one exported by GnuCash.

 

Import Transactions from CSV...

Starts the CSV Transactions file import process. The file to import must be a delimited file.

 

Replay GnuCash .log file...

Starts the replaying of a GnuCash log file. Used for data recovery from "crashes".

 

Import MT940

.

 

Import MT942

.

 

Import DTAUS

.

 

Import DTAUS and send

.

 

Import Bills & Invoices...

Open the Import Transactions from text file window.

 

Import Customers and Vendors ...

Open the Import Customers and Vendors from text file window.

Save (Ctrl+S)

Saves the currently open file.

Save As... (Shift+Ctrl+S)

Saves the currently opened file with a different name.

Warning

Do NOT store your data file in ~/.gnucash/books.

Revert

Reload the last saved version of the currently opened file. Useful if you need to discard changes made to the data and not yet saved.

Print Report... (Ctrl+P)

Print the selected report.

Page Setup... (Shift+Ctrl+P)

Let you choose the paper size, layout and margins for printing.

Export as PDF

Exports the displayed report as a PDF file.

Export

Opens the Export sub-menu.

 

Export Accounts Tree to CSV

Exports your account hierarchy to a delimited CSV file. Does not export data.

 

Export Transactions to CSV

Exports transactions to a delimited CSV file.

 

Export Report

Export the current report in an HTML formatted file.

 

Export Accounts

Exports your account hierarchy to a new GnuCashfile. Does not export data.

Properties (Alt+Enter)

Sets options for this GnuCash data file.

Recently opened files

Numbered list of most recently opened GnuCash data files.

Close (Ctrl+W)

Closes the current report.

Quit (Ctrl+Q)

Exits GnuCash.


4.4.2.2. Report - Edit Menu

Table 4.18. Reports - Edit Menu - Access to file and account editing operations and preferences.

Menu Item

Description

Cut (Ctrl+X)

Performs a standard Cut operation.

Copy (Ctrl+C)

Performs a standard Copy operation.

Paste (Ctrl+V)

Performs a standard Paste operation.

Find... (Ctrl+F)

Set criteria for a search for a specific transaction. See Section 8.1, “Find” for specifics on searches.

Preferences (GnuCashPreferences on Mac OS X).

Customize GnuCash for location, style, and numerous other preferences. See Section 10.2, “Setting Preferences”.

Style Sheets

Modify/customize Style Sheets.

Report Options

Open form to edit/modify report selection criteria, stylesheets, date ranges, and many other parameters.

Tax Report Options

Set tax characteristics on account(s) (US). Assign tax form and line to account. See Section 10.5, “Setting Tax Report Options”.


4.4.2.3. Report - View Menu

Except Filter By..., the items shown in the View menu are the same as listed in Table 4.3, “Account Tree - View Menu - Changes display window view.”

4.4.2.4. Report - Actions Menu

Table 4.19. Reports - Actions Menu - Setup scheduled transactions.

Menu Item

Description

Online Actions

This menu item (and sub-menu) is shown only if Online Banking was enabled for GnuCash
 

Show log window...

Open the Online Banking Connection Window

Scheduled Transactions

Scheduled Transactions sub-menus
 

Scheduled Transaction Editor

Invoke tool to edit scheduled transactions. See Section 6.13, “Edit Scheduled Transaction Window”

 

Since Last Run...

Display Scheduled transactions since last running of GnuCash. Section 8.2, “Since Last Run Assistant”

 

Mortgage & Loan Repayment...

Starts the Mortgage & Loan Repayment assistant for setting up repayments. Section 8.3, “Mortgage & Loan Repayment Assistant”

Budget

Budget sub-menus
 

New Budget

Opens the window to create a new budget.

 

Open Budget

Opens an existing budget.

 

Copy Budget

Copy a budget.

Reset Warnings...

GnuCash gives warnings when certain operations are attempted, such as removing a transaction or removing the splits of a transaction. The warning message gives you the option to not give you these warnings when attempting the operation. Check-boxes labeled Remember and don’t ask me again and Remember and don’t ask me again this session allow disabling the warnings. This option resets the warnings to the default, This option resets the warnings to the default, i.e. display all warnings.

Tip

Warnings may be selectively enabled.

Rename Page

Lets you type a new name for the current page or tab.


4.4.2.5. Report - Business Menu

The items shown in the Business menu are the same as listed in Table 4.5, “Account Tree - Business Menu - Access small business features of GnuCash.”.

4.4.2.6. Report - Reports Menu

The items shown in the Reports menu are the same as listed in Table 4.6, “Account Tree - Reports Menu - Access GnuCash Reports and Charts.” with the addition of:

Table 4.20. Report - Reports Menu.

Menu Item

Description

Save Report Configuration

Save the current report configuration. If you are not working with a saved report configuration, you will be asked to give it a name. You will be able to run the exact same report again by using the Reports Saved Report Configurations menu item.

Save Report Configuration As...

Save the current report configuration with a new name.


4.4.2.7. Report - Tools Menu

The items shown in the Tools menu are the same as listed in Table 4.7, “Account Tree - Tools Menu - Access to miscellaneous tools and editors”.

4.4.2.8. Report - Windows Menu

The items shown in the Windows menu are the same as listed in Table 4.8, “Account Tree - Windows Menu”.

4.4.2.9. Report - Help Menu

The items shown in the Help menu are the same as listed in Table 4.9, “Account Tree - Help Menu - Access to this help and the Tutorial and Concepts Guide.”.

4.4.3. Reports - Toolbar Icons/Buttons

The Report Window has a Toolbar to quickly access the functions used with reports. The Toolbar can be hidden or shown by selecting ViewToolbar.

Table 4.21. Reports - Toolbar Buttons

Toolbar Button

Description

Save (Ctrl+S)

Close (Ctrl+W)

Closes the displayed report.

Back

Move back one step in the history.

Forward

Move forward one step in the history.

Reload

Reload (rerun) current report.

Stop

Stops the HTML requests.

Save Report Configuration

Saves the displayed report. You will be able to run the exact same report again by using the ReportsSaved Report Configurations menu item.

Save Report Configuration As...

Saves the displayed report in a configuration file with a given name. You will then be able to run the exact same report again by using the ReportsSaved Report Configurations menu item.

Export

Exports HTML formatted report to a file.

Options

Edit options specific to selected report.

Print (Ctrl+P)

Queues the current report for printing.

Export as PDF

Exports the selected report as a PDF file.


4.4.4. Tab Bar

The Tab bar displays notebook/file folder-style tabs for open transaction registers, account trees and reports.

4.4.5. Report Main Display

This is where the report or chart you have selected is shown. The properties of this window are editable in two ways. Selecting the Options button on the Toolbar lets you edit what the report is showing and which accounts the information is drawn from. Selecting EditStyle Sheets... lets you select the properties of the page that displays your report.

The report is able to act like a web browser if your report contains links to external web pages. The Toolbar buttons allow you to move Back and Forward through web pages. It will also open account registers when you click on links to accounts contained in the report.

You can also Export your report to a file and Print the report through the Toolbar buttons.

4.4.6. Summarybar

The Summarybar is not displayed when viewing a report window.

4.4.7. Statusbar

The Statusbar works the same as described in Section 4.2.6, “Statusbar”.