4.4. Janela de relatórios

4.4.1. Janela de exibição de relatórios

Esta janela é mostrada sempre que um relatório ou gráfico é selecionado no menu Relatórios na barra de menus.

A janela oferee uma página tipo navegador web, com ligações ativas à área de contabilidade.

Nota

Dependendo do relatório, pode haver um tempo de espera enquanto o relatório é gerado. É mostrada na barra de estado uma aproximação ao tempo de conclusão, se não optou por a ocultar.

Figura 4.4. A janela de relatórios

Ecrã de relatórios

Eis uma imagem do gráfico de Cronologia das despesas.


4.4.2. Menus dos relatórios

A barra de menus das janelas de relatórios contém as seguintes opções:

4.4.2.1. Relatórios - menu Ficheiro

A tabela seguinte descreve as opções do menu ficheiro.

Clicar na opção Ficheiro da barra de menus vai abrir um menu de opções descritas em Tabela 4.17, “Relatórios - menu Ficheiro - acesso a operações de ficheiros, contas e impressão.”.

Tabela 4.17. Relatórios - menu Ficheiro - acesso a operações de ficheiros, contas e impressão.

Item de menu

Descrição

Novo ficheiro (Ctrl+N)

Cria um novo ficheiro de dados (começa com novas contas e dados.)

Abrir... (Ctrl+O)

Abre um ficheiro já existente do GnuCash.

Importar

Abre o submenu Importar para importar ficheiros de outros programas, dados diversos, planos de contas, etc.

 

Importar QIF...

Inicia o processo de importação de ficheiro QIF.

 

Importar OFX/QFX...

Inicia o processo de importação de ficheiro OFX/QFX.

 

Importar contas de CSV...

Inicia o processo de importação de ficheiro de contas CSV. O ficheiro a importar tem de estar no mesmo formato de exportação do GnuCash.

 

Importar transações de CSV...

Inicia o processo de importação de ficheiro de transações CSV. O ficheiro a importar tem de ser um ficheiro delimitado.

 

Reproduzir ficheiro .log do GnuCash...

Inicia a reprodução do ficheiro de atividades do GnuCash. Usado para recuperação de dados em caso de incidente fatal.

 

Importar MT940

.

 

Importar MT942

.

 

Importar DTAUS

.

 

Importar DTAUS e enviar

.

 

Importar pagamentos e faturas...

Abre a janela de importação de transações a partir de ficheiro de texto.

 

Importar clientes e fornecedores...

Abre a janela de importação de clientes e fornecedores a partir de ficheiro de texto.

Gravar (Ctrl+S)

Grava o ficheiro atualmente aberto.

Gravar como... (Shift+Ctrl+S)

Grava o ficheiro atual com um nome diferente.

Atenção

NÃO armazene o seu ficheiro de dados em ~/.gnucash/books.

Reverter

Recarrega a última versão do gravada do ficheiro atualmente aberto. Útil se precisar de descartar alterações que ainda não foram gravadas.

Gravar relatório

Grava o relatório mostrado. Poderá executar exatamente o mesmo relatório de novo, usando RelatóriosRelatório predefinido.

Gravar relatório como...

Grava o relatório mostrado num ficheiro de configuração com um dado nome. Poderá executar exatamente o mesmo relatório de novo, usando RelatóriosRelatório predefinido.

Imprimir relatório... (Ctrl+P)

Imprime o relatório selecionado.

Configurar página... (Shift+Ctrl+P)

Permite-lhe escolher o tamanho do papel, a disposição e as margens da impressão.

Exportar como PDF

Exporta o relatório mostrado como ficheiro PDF.

Exportar

Abre o submenu Exportar.

 

Exportar contas para CSV

Exporta a sua hierarquia de contas para um ficheiro delimitado CSV. Não exporta dados.

 

Exportar transações CSV

Exporta transações para um ficheiro delimitado CSV.

 

Exportar relatório

Exporta o relatório atual para um ficheiro formatado como HTML.

 

Exportar contas

Exporta a sua hierarquia de contas para um novo ficheiro do GnuCash. Não exporta dados.

Propriedades (Alt+Enter)

Define as opções para este ficheiro de dados GnuCash.

Lista de ficheiros recentes

Lista numerada dos ficheiros do GnuCash mais recentemente abertos.

Fechar (Ctrl+W)

Fecha o separador atual.

Sair (Ctrl+Q)

Sai do GnuCash.


4.4.2.2. Relatórios - menu Editar

Tabela 4.18. Relatórios - menu Editar - acesso a operações de edição de ficheiro e contas e a preferências.

Item de menu

Descrição

Cortar (Ctrl+X)

Realiza uma operação padrão de corte.

Copiar (Ctrl+C)

Realiza uma operação padrão de cópia.

Colar (Ctrl+V)

Realiza uma operação padrão de colagem.

Localizar... (Ctrl+F)

Define um critério para procurar uma transação específica. Veja Secção 8.1, “Procurar” para mais detalhes sobre procuras.

Preferências (GnuCashPreferências em Mac OS X).

Personalizar o GnuCash na localização, estilo e muitas outras opções. Veja Secção 10.2, “Definir preferências”.

Folhas de estilo

Modifica/personaliza folhas de estilo. Veja Secção 10.4, “Alterar folhas de estilo”.

Opções do relatório

Abre o formulário para editar/modificar critérios de seleção, folhas de estilo, intervalos de data e muitos outros parâmetros dos relatórios.

Opções do relatório Impostos

Define características de impostos das contas (EUA). Atribui um formulário de impostos e um campo de formulário à conta. Veja Secção 10.5, “Definir opções do relatório Impostos”


4.4.2.3. Relatórios - menu Ver

Exceto Filtrar por..., os itens mostrados no menu Ver são os mesmos listados em Tabela 4.3, “Árvore de contas - menu Ver - altera a vista da janela.”

4.4.2.4. Relatório - menu Ações

Tabela 4.19. Relatórios - menu Ações - configurar transações agendadas.

Item de menu

Descrição

Ações online

Este item de menu (e submenu) só é mostrado se o Online Banking foi ativado para o GnuCash
 

Mostrar janela de registo...

Abre a janela de ligação ao Online Banking

Transações agendadas

Submenu das transações agendadas
 

Editor de transações agendadas

Abre a ferramenta para editar transações agendadas. Veja Secção 6.13, “Janela de edição de transações agendadas”

 

Desde a última execução...

Mostrar transações agendadas desde a última execução do GnuCash. Secção 8.2, “Assistente Desde a última execução”

 

Amortização de hipotecas e empréstimos...

Inicia o assistente para definir o plano de amortização de hipotecas e empréstimos. Secção 8.3, “Amortização de hipotecas e empréstimos”

Orçamento

Submenu de orçamentos
 

Novo orçamento

Abre a janela para criar um novo orçamento.

 

Abrir orçamento

Abre um orçamento existente.

 

Copiar orçamento

Copia um orçamento.

Repor avisos...

O GnuCash avisa quando certas operações são tentadas, tais como remover uma transação ou remover parcelas de uma transação. A mensagem dá-lhe a opção de não voltar a ser avisado quando tentar a operação. As caixas Lembrar e não perguntar novamente e Lembrar e não perguntar novamente nesta sessão permitem-lhe desativar os avisos. Esta opção repõe a predefinição dos avisos, i. e., mostrar todos os avisos.

Dica

Os avisos podem ativados seletivamente.

Renomear página

Abre o formulário para renomear a página/separador atual.


4.4.2.5. Relatórios - menu Negócios

Os itens mostrados no menu Negócios são os mesmos listados em Tabela 4.5, “Árvore de contas - menu Negócios - acesso a funcionalidades do GnuCash para pequenos negócios.”.

4.4.2.6. Relatórios - menu Relatórios

Os itens mostrados no menu Relatórios são os mesmos listados em Tabela 4.6, “Árvore de contas - menu Relatórios - acesso aos relatórios e gráficos do GnuCash.”.

4.4.2.7. Relatórios - menu Ferramentas

Os itens mostrados no menu Ferramentas são os mesmos listados em Tabela 4.7, “Árvore de contas - menu Ferramentas - acesso a ferramentas e editores diversos”.

4.4.2.8. Relatórios - menu Janelas

Os itens mostrados no menu Janelas são os mesmos listados em Tabela 4.8, “Árvore de contas - menu Janelas.

4.4.2.9. Relatórios - menu Ajuda

Os itens mostrados no menu Ajuda são os mesmos listados em Tabela 4.9, “Árvore de contas - menu Ajuda - acesso a esta ajuda e ao Tutorial e guia de conceitos.”.

4.4.3. Relatórios - ícones/botões da barra de ferramentas

A janela de relatórios tem uma barra de ferramentas para aceder rapidamente às funções usadas com relatórios. A barra de ferramentas pode ser ocultada ou mostrada, selecionando VerBarra de ferramentas.

Tabela 4.20. Relatórios - botões da barra de ferramentas

Botão da barra de ferramentas

Descrição

Gravar (Ctrl+S)

Fechar (Ctrl+W)

Fecha o relatório mostrado.

Recuar

Recua um passo no histórico.

Avançar

Avança um passo no histórico.

Recarregar

Recarrega (atualiza) o relatório atual.

Parar

Pára os pedidos HTML pendentes.

Gravar relatório

Grava o relatório mostrado. Poderá executar exatamente o mesmo relatório de novo, usando RelatóriosRelatórios predefinidos.

Gravar relatório como

Grava o relatório mostrado num ficheiro de configuração com um dado nome. Poderá executar exatamente o mesmo relatório de novo, usando RelatóriosRelatórios predefinidos.

Exportar

Exporta o relatório em formato HTML para um ficheiro.

Opções

Editar opções específicas do relatório selecionado.

Imprimir (Ctrl+P)

Põe o relatório atual na fila de impressão.

Exportar como PDF

Exporta o relatório selecionado como ficheiro PDF.


4.4.4. Barra de separadores

A barra de separadores mostra separadores estilo arquivo de ficheiros para ver os vários diários de transações, relatórios e a árvore de contas.

4.4.5. Janela principal de relatórios

É aqui que o relatório ou gráfico que escolheu é mostrado. As propriedades desta janela são editáveis de duas formas. Selecionando o botão Opções na barra de ferramentas permite-lhe editar aquilo que é mostrado no relatório e de que contas a informação é retirada. Selecionando EditarFolhas de estilo... permite-lhe selecionar as propriedades da página que mostra o seu relatório.

Os relatórios podem comportar-se como um navegador web, se dispuserem de hiperligações a páginas web externas. Os botões da barra de ferramentas permitem-lhe Recuar e Avançar nas páginas web. Também abrem diários de conta quando clica nas ligações a contas contidas no relatório.

Pode também exportar o seu relatório para um ficheiro e imprimir o relatório através dos botões da barra de ferramentas.

4.4.6. Barra de sumário

A barra de sumário não é mostrada durante a exibição de uma janela de relatório.

4.4.7. Barra de estado

A barra de estado funciona da mesma maneira que o descrito em Secção 4.2.6, “Barra de estado”.