4.4. Report Window

4.4.1. Report Display Window

This window is shown whenever a report or chart is selected from the Reports menu.

To open the report window, select a report from the Reports item in the Menubar. This will open a new window with the report displayed. It provides a web browser type display with active links to account data.

Note

Depending on the report there may be a delay while the report is generated. An approximation of the progress to completion is displayed in the Statusbar, if has not been opted out of displaying.

Figure 4.4. The Report Window

Report screen

This is an image of the Income/Expense Chart.


4.4.2. Report Menus

The Menubar for the report window contains the following options.

4.4.2.1. Reports - File Menu

Clicking on the File option of the Menubar will pull down a menu of options described in Table 4.1, “Account Tree - File-Menu - Access to file, account operations and printing.”.

In addition, these menu items are available.

Table 4.18. Report - File-Menu - Access to file and account operations and printing.

Menu Item

Description

Print Report... (Ctrl+P)

Print the selected report.

Export

Opens the Export sub-menu.

 

Export Report

Export the current report in an HTML formatted file.

Close (Ctrl+W)

Closes the current report.


4.4.2.2. Report - Edit Menu

The items shown in the Edit menu are the same as listed in Table 4.2, “Account Tree - Edit-Menu - Access to file and account editing operations and preferences.” plus the items listed in the following.

Table 4.19. Reports - Edit-Menu - Access to file and account editing operations and preferences.

Menu Item

Description

Report Options

Open form to edit/modify report selection criteria, stylesheets, date ranges, and many other parameters.


4.4.2.3. Report - View Menu

Except Filter By..., the items shown in the View menu are the same as listed in Table 4.3, “Account Tree - View-Menu - Changes display window view.”

4.4.2.4. Report - Actions Menu

The items shown in the Actions menu are the same as listed in Table 4.4, “Account Tree - Actions-Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.”.

However, the number of menu items is considerably reduced.

4.4.2.5. Report - Business Menu

The items shown in the Business menu are the same as listed in Table 4.5, “Account Tree - Business-Menu - Access small business features of GnuCash.”.

4.4.2.6. Report - Reports Menu

The items shown in the Reports menu are the same as listed in Table 4.6, “Account Tree - Reports-Menu - Access GnuCash Reports and Charts.” with the addition of:

Table 4.20. Report - Reports-Menu - Access GnuCash Reports and Charts.

Menu Item

Description

Save Report Configuration (Ctrl+Alt+S)

Save the current report configuration. If you are not working with a saved report configuration, you will be asked to give it a name. You will be able to run the exact same report again by using the Reports Saved Report Configurations menu item.

Save Report Configuration As... (Shift+Ctrl+Alt+S)

Add the current report's configuration to the ReportsSaved Report Configurations menu.


4.4.2.7. Report - Tools Menu

The items shown in the Tools menu are the same as listed in Table 4.7, “Account Tree - Tools-Menu - Access to miscellaneous tools and editors”.

4.4.2.8. Report - Windows Menu

The items shown in the Windows menu are the same as listed in Table 4.8, “Account Tree - Windows-Menu”.

4.4.2.9. Report - Help Menu

The items shown in the Help menu are the same as listed in Table 4.9, “Account Tree - Help-Menu - Access to this help and the Tutorial and Concepts Guide.”.

4.4.3. Reports - Toolbar Icons/Buttons

The Report Window has a Toolbar to quickly access the functions used with reports. The Toolbar can be hidden or shown by selecting ViewToolbar .

Note

The specific options displayed in the Toolbar vary with the functions available to the active tab.

Tip

A brief description of the function of a Toolbar button is displayed when the mouse pointer is placed over the icon for a couple of seconds.

Table 4.21. Reports - Toolbar Buttons

Toolbar Button

Description

Save

Perform a save on the data file, commit all transactions to the data file.

Note

Only active if changed data has not yet been saved.

Close

Closes the displayed report.

Note

This icon is not available for the first accounts tab. It is available for additional account tree displays.

Back

Move back one step in the history.

Forward

Move forward one step in the history.

Reload

Reload (rerun) current report.

Stop

Stops the HTML requests.

Options

Edit options specific to selected report.

Save Report Configuration

Saves the displayed report. You will be able to run the exact same report again by using the ReportsSaved Report Configurations menu item.

Save Report Configuration As...

Saves the displayed report in a configuration file with a given name. You will then be able to run the exact same report again by using the ReportsSaved Report Configurations menu item.

Export

Exports HTML formatted report to a file.

Print

Queues the current report for printing.


4.4.4. Tab Bar

The Tab bar displays notebook/file folder-style tabs for open transaction registers, account trees and reports.

4.4.5. Report Main Display

This is where the report or chart you have selected is shown. The properties of this window are editable in two ways. Selecting the Options button on the Toolbar lets you edit what the report is showing and which accounts the information is drawn from. Selecting EditStyle Sheets... lets you select the properties of the page that displays your report.

The report is able to act like a web browser if your report contains links to external web pages. The Toolbar buttons allow you to move Back and Forward through web pages. It will also open account registers when you click on links to accounts contained in the report.

You can also Export your report to a file and Print the report through the Toolbar buttons.

4.4.6. Summarybar

The Summarybar is not displayed when viewing a report window.

4.4.7. Statusbar

The Statusbar works the same as described in Section 4.2.6, “Statusbar”.